Mandatory Client Upgrade to BTCS v.2.1.0 by Block 730,000

We have an important announcement.

All wallets must upgrade to BTCS v.2.1 before block 730,000.

An issue involving difficulty retargeting was fixed so now all clients must upgrade to Bitcoin-sCrypt Wallet client v.2.1. The deadline is set to block 730,000.

The latest code can be found here: https://github.com/Bitcoin-sCrypt/Bitcoin-sCrypt
Windows and Mac wallets can be found here: https://bitcoinscrypt.io

Finally, hybrid Proof-of-Stake is enabled and running on the network so users can generate coins and help the network by staking their coins.

Please follow and like us: